Filtered |
Applies a WorksetKindFilter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- worksetKind WorksetKind
- The WorksetKind of the workset.
Return Value
FilteredWorksetCollectorA handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.
If you have an active iterator to this collector it will be stopped by this call.