Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to look for the linked model in.
- reference
- Type: Autodesk.Revit.DB ExternalResourceReference
An ExternalResourceReference indicating which linked model to return.
Return Value
The id of the link with the given ExternalResourceReference, or InvalidElementId if there is no top-level link at that location.Remarks
This function will not return nested links.
Revit will not check the version when checking for resource equality.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |