Revit |
Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElementId GetTopLevelLink(
Document document,
ExternalResourceReference reference
)
Parameters
- document Document
- The document to look for the linked model in.
- reference ExternalResourceReference
- An ExternalResourceReference indicating which linked model to return.
Return Value
ElementIdThe id of the link with the given ExternalResourceReference, or InvalidElementId if there is no top-level link at that location.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function will not return nested links.
Revit will not check the version when checking for resource equality.