Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shape
- Type: Autodesk.Revit.DB.Mechanical DuctShape
The shape of duct.
- nominalDiameter
- Type: System Double
Nominal diameter.
Remarks
Does nothing if there is no existing MEPSize with this nominal diameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | Throws if the function is called during iterating the size set. |