RemoveSize Method


Duct Size Settings Remove Size Method

Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveSize(
	DuctShape shape,
	double nominalDiameter
)

Parameters

shape DuctShape
The shape of duct.
nominalDiameter Double
Nominal diameter.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Throws if the function is called during iterating the size set.
Remarks
Does nothing if there is no existing MEPSize with this nominal diameter.
See Also