Identifies if the particular element is valid for iteration of drawn elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- viewId
- Type: Autodesk.Revit.DB ElementId
The view id.
Return Value
True if the element is valid for iteration.Remarks
Views that have no way of representing drawn elements, such as many view templates, fail this check.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |