IsViewValidForElementIteration Method


Filtered Element Collector Is View Valid For Element Iteration Method

Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsViewValidForElementIteration(
	Document document,
	ElementId viewId
)

Parameters

document Document
The document.
viewId ElementId
The view id.

Return Value

Boolean
True if the element is valid for iteration.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Views that have no way of representing drawn elements, such as many view templates, fail this check.
See Also