Create a new RibbonPanel on the Add-Ins tab.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.1090.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- panelName
- Type: System String
The name of the panel to be created.
Remarks
This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | panelName is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | panelName is Empty. |
Autodesk.Revit.Exceptions InvalidOperationException | If more than 100 panels were created. |