CreateRibbonPanel Method (String)


Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
	string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
	panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
	String^ panelName
)

Parameters

panelName
Type: SystemString
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionpanelName is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionpanelName is Empty.
Autodesk.Revit.ExceptionsInvalidOperationExceptionIf more than 100 panels were created.

See Also