Associates or disassociates the element parameter to an existing family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementParameter
- Type: Autodesk.Revit.DB Parameter
The parameter of an element in family.
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
The existing family parameter. If the input to this argument is a null reference ( Nothing in Visual Basic) , it will disassociate the element parameter from any family parameters.
Remarks
The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument-"elementParameter"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the family parameter binding failed. |