AssociateElementParameterToFamilyParameter Method


Family Manager Associate Element Parameter To Family Parameter Method

Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AssociateElementParameterToFamilyParameter(
	Parameter elementParameter,
	FamilyParameter familyParameter
)

Parameters

elementParameter Parameter
The parameter of an element in family.
familyParameter FamilyParameter
The existing family parameter. If the input to this argument is , it will disassociate the element parameter from any family parameters.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"elementParameter"-is .
ArgumentException Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
InvalidOperationException Thrown when the family parameter binding failed.
Remarks
The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.
See Also