CheckExportCategory Method


Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public static bool CheckExportCategory(
	ElementId exportCategoryId
)
Visual Basic
Public Shared Function CheckExportCategory ( _
	exportCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckExportCategory(
	ElementId^ exportCategoryId
)

Parameters

exportCategoryId
Type: Autodesk.Revit.DB ElementId
The export category to be checked.

Return Value

True if the export category falls within the list, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also