Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle,
and assigns them to the file.
Namespace:
Autodesk.Revit.DB.IFC
Assembly:
RevitAPIIFC
(in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
-
Type:
Autodesk.Revit.DB.IFC
ExporterIFC
The exporter.
- repItem
-
Type:
Autodesk.Revit.DB.IFC
IFCAnyHandle
The representation item.
- color
-
Type:
Autodesk.Revit.DB
Color
The color.
- fillPatternId
-
Type:
Autodesk.Revit.DB
ElementId
The fill pattern id.
Return Value
The handle.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | A transaction is required for this operation. |