CreateStyle Method (ExporterIFC, IFCAnyHandle, Color, ElementId)


IFCFile Create Style(Exporter IFC, IFCAny Handle, Color, Element Id) Method

Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCAnyHandle CreateStyle(
	ExporterIFC exporterIFC,
	IFCAnyHandle repItem,
	Color color,
	ElementId fillPatternId
)

Parameters

exporterIFC ExporterIFC
The exporter.
repItem IFCAnyHandle
The representation item.
color Color
The color.
fillPatternId ElementId
The fill pattern id.

Return Value

IFCAnyHandle
The handle.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException A transaction is required for this operation.
See Also