DataTransferProgressChangedEventArgs Class


The event arguments used during the data transferring phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017 Subscription Update

Syntax

C#
public class DataTransferProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs
Visual Basic
Public Class DataTransferProgressChangedEventArgs _
	Inherits WorksharedOperationProgressChangedEventArgs
Visual C++
public ref class DataTransferProgressChangedEventArgs : public WorksharedOperationProgressChangedEventArgs

Remarks

It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time.

Inheritance Hierarchy

See Also