DataTransferProgressChangedEventArgs Class


Data Transfer Progress Changed Event Args Class

The event arguments used during the data transferring phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DataTransferProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs

The DataTransferProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property FinishedSize The transferred data size, in bytes, since the last time this event was raised.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Public property Location Full path of the central model which is to be operated.
(Inherited from WorksharedOperationProgressChangedEventArgs )
Public property Speed Speed(bytes/second) in this event.
Public property Status Gets API event status, reflect current operation execution status.
(Inherited from WorksharedOperationProgressChangedEventArgs )
Public property TotalSize Total expected data size to transfer, in bytes.
Public property TransferMode Data transfer mode in this event.
Top
Methods
Name Description
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time.
See Also