DataTransferProgressChangedEventArgs Class


Data Transfer Progress Changed Event Args Class

The event arguments used during the data transferring phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DataTransferProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs

The DataTransferProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property FinishedSize The transferred data size, in bytes, since the last time this event was raised.
Public property Speed Speed(bytes/second) in this event.
Public property TotalSize Total expected data size to transfer, in bytes.
Public property TransferMode Data transfer mode in this event.
Top
Methods
Name Description
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time.
See Also