DoesBarExistAtPosition Method


Checks whether a bar is included at the specified position.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public bool DoesBarExistAtPosition(
	int barPosition
)
Visual Basic
Public Function DoesBarExistAtPosition ( _
	barPosition As Integer _
) As Boolean
Visual C++
public:
bool DoesBarExistAtPosition(
	int barPosition
)

Parameters

barPosition
Type: System Int32
A bar position index between 0 and NumberOfBarPositions-1.

Return Value

Returns true if the bar at the specified position is included, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException barPosition is not in the range [ 0, NumberOfBarPositions-1 ].

See Also