Gets the direction of the layer. The lines are distributed along this direction.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layer
- Type: Autodesk.Revit.DB.Structure AreaReinforcementLayerType
The layer type.
Return Value
Returns the direction of the desired layer.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InapplicableDataException | The layer layer isn't active. |