Enum to specify the task dialog result.
Namespace:
Autodesk.Revit.UI
Assembly:
RevitAPIUI
(in RevitAPIUI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
None | Nothing is returned from the task dialog. |
Ok | The return value for TaskDialogCommonButtons.Ok. |
Cancel | The return value for TaskDialogCommonButtons.Cancel or the task dialog is cancelled by ESC, Alt+F4 or the X close button. |
Retry | The return value for TaskDialogCommonButtons.Retry. |
Yes | The return value for TaskDialogCommonButtons.Yes. |
No | The return value for TaskDialogCommonButtons.No. |
Close | The return value for TaskDialogCommonButtons.Close. |
CommandLink1 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink1. |
CommandLink2 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink2. |
CommandLink3 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink3. |
CommandLink4 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink4. |