TaskDialogResult Enumeration


Task Dialog Result Enumeration

Enum to specify the task dialog result.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum TaskDialogResult
Members
Member name Value Description
Cancel 2 The return value for TaskDialogCommonButtons.Cancel or the task dialog is cancelled by ESC, Alt+F4 or the X close button.
Close 8 The return value for TaskDialogCommonButtons.Close.
CommandLink1 1,001 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink1.
CommandLink2 1,002 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink2.
CommandLink3 1,003 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink3.
CommandLink4 1,004 The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink4.
No 7 The return value for TaskDialogCommonButtons.No.
None 0 Nothing is returned from the task dialog.
Ok 1 The return value for TaskDialogCommonButtons.Ok.
Retry 4 The return value for TaskDialogCommonButtons.Retry.
Yes 6 The return value for TaskDialogCommonButtons.Yes.
See Also