Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hermiteSpline
- Type: Autodesk.Revit.DB HermiteSpline
The HermiteSpline that will be converted.
Return Value
The new Curve object.Remarks
The function does not support periodic Hermite curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given hermite spline has to be non-periodic. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |