Nurb |
Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- hermiteSpline HermiteSpline
- The HermiteSpline that will be converted.
Return Value
CurveThe new Curve object.

Exception | Condition |
---|---|
ArgumentException | The given hermite spline has to be non-periodic. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |
ArgumentNullException | A non-optional argument was NULL |

The function does not support periodic Hermite curve.