Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elemId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the Element which the external file reference is a component of.
Return Value
An ExternalFileReference containing the requested path and load status information for an external fileExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |