GetDesiredReferenceData Method


Transmission Data Get Desired Reference Data Method

Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternalFileReference GetDesiredReferenceData(
	ElementId elemId
)

Parameters

elemId ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

ExternalFileReference
An ExternalFileReference containing the requested path and load status information for an external file
Exceptions
Exception Condition
ArgumentException elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
ArgumentNullException A non-optional argument was null
See Also