The cross product of this vector and the specified vector.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
-
Type:
Autodesk.Revit.DB
XYZ
The vector to multiply with this vector.
Return Value
The vector equal to the cross product.Remarks
The cross product is defined as the vector which is perpendicular to both vectors
with a magnitude equal to the area of the parallelogram they span.
Also known as vector product or outer product.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when source is a null reference ( Nothing in Visual Basic) . |