The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: DisplayStyle cannot be set to Undefined. -or- When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: DisplayStyle cannot be modified. -or- When setting this property: This view does not contain display-related properties. |