DisplayStyle Property


View Display Style Property

The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DisplayStyle DisplayStyle { get; set; }

Property Value

DisplayStyle
Exceptions
Exception Condition
ArgumentException When setting this property: DisplayStyle cannot be set to Undefined. -or- When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: DisplayStyle cannot be modified. -or- When setting this property: This view does not contain display-related properties.
See Also