Sets all input diameters from diametersOptions in current RebarBarType.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- diametersOptions
- Type: Autodesk.Revit.DB BarTypeDiameterOptions
The input diameters are validated as follows : barModelDiameter and barNominalDiameter are both positive and no more than the smallest value of 1.0 and the input bend diameters. Each bend diameter is smaller than 99.0 and bigger than barDiameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the diameters ranges in diametersOptions are not acceptable. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |