Rebar |
Sets all input diameters from diametersOptions in current RebarBarType.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- diametersOptions BarTypeDiameterOptions
- The input diameters are validated as follows : barModelDiameter and barNominalDiameter are both positive and no more than the smallest value of 1.0 and the input bend diameters. Each bend diameter is smaller than 99.0 and bigger than barDiameter.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | the diameters ranges in diametersOptions are not acceptable. |