Creates a new instance of MemberForces.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- start
- Type: System Boolean
Member Forces position on analytical element. True for start, false for end.
- force
- Type: Autodesk.Revit.DB XYZ
The Translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the analytical element coordinate system, y along y-axis, z along z-axis respectively.
- moment
- Type: Autodesk.Revit.DB XYZ
The Rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the analytical element coordinate system, y about y-axis, z about z-axis respectively.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |