Member |
Creates a new instance of MemberForces.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- start Boolean
- Member Forces position on analytical element. True for start, false for end.
- force XYZ
- The Translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the analytical element coordinate system, y along y-axis, z along z-axis respectively.
- moment XYZ
- The Rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the analytical element coordinate system, y about y-axis, z about z-axis respectively.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |