GetCurveUV Method (Int32, Transform2D)


Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021

Syntax

C#
public CurveUV GetCurveUV(
	int index,
	Transform2D transform
)
Visual Basic
Public Function GetCurveUV ( _
	index As Integer, _
	transform As Transform2D _
) As CurveUV
Visual C++
public:
CurveUV^ GetCurveUV(
	int index, 
	Transform2D^ transform
)

Parameters

index
Type: System Int32
The index of the face (0 or 1).
transform
Type: Autodesk.Revit.DB Transform2D
Transformation to apply to the curve.

Return Value

If successful, returns the calculated and transformed CurveUV, a null reference ( Nothing in Visual Basic) otherwise.

Remarks

Use of this function is preferred over using GetCurveUV(int index) and then transforming the curve, as the latter approach may yield a less accurate result.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException Thrown when the specified index is not 0 or 1.

See Also