Edge Get |
Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- index Int32
- The index of the face (0 or 1).
- transform Transform2D
- Transformation to apply to the curve.
Return Value
CurveUVIf successful, returns the calculated and transformed CurveUV, otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1. |

Use of this function is preferred over using GetCurveUV(int index) and then transforming the curve, as the latter approach may yield a less accurate result.