View Property


The view used for geometry extraction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
	Get
	Set
Visual C++
public:
property View^ View {
	View^ get ();
	void set (View^ value);
}

Remarks

If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when setting this property with a a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions InvalidOperationException Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.

See Also