View Property


Options View Property

The view used for geometry extraction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public View View { get; set; }

Property Value

View
Exceptions
Exception Condition
ArgumentNullException Thrown when setting this property with a .
InvalidOperationException Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.
Remarks
If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.
See Also