Creates an instance of the DeleteElements resolution.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document which owns the elements to delete.
- ids
-
Type:
System.Collections.Generic
ISet
ElementId
The ids of the elements that will be deleted when this resolution is chosen.
Return Value
The instance of the DeleteElements resolution.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input ids is empty or contains an invalid element id. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |