Delete |
Creates an instance of the DeleteElements resolution.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document which owns the elements to delete.
- ids ISet ElementId
- The ids of the elements that will be deleted when this resolution is chosen.
Return Value
FailureResolutionThe instance of the DeleteElements resolution.

Exception | Condition |
---|---|
ArgumentException | The input ids is empty or contains an invalid element id. |
ArgumentNullException | A non-optional argument was null |