Validates that the wall is of a type that may be a host for a wall sweep or reveal.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wall
- Type: Autodesk.Revit.DB Wall
The wall.
Return Value
True if the wall may host a wall sweep, false otherwise.Remarks
This function excludes curtain walls and the main wall of a set of stacked walls. The wall must be fully regenerated for this function to work correctly.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |