WallAllowsWallSweep Method


Wall Sweep Wall Allows Wall Sweep Method

Validates that the wall is of a type that may be a host for a wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool WallAllowsWallSweep(
	Wall wall
)

Parameters

wall Wall
The wall.

Return Value

Boolean
True if the wall may host a wall sweep, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function excludes curtain walls and the main wall of a set of stacked walls. The wall must be fully regenerated for this function to work correctly.
See Also