Creates new unplaced rooms in the given phase.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- phase
- Type: Autodesk.Revit.DB Phase
The phase on which the rooms are to exist.
- count
- Type: System Int32
The number of the rooms to be created.
Return Value
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the phase does not exist in the given document. |