NewRooms2 Method (Phase, Int32)


Document New Rooms 2(Phase, Int 32) Method

Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> NewRooms2(
	Phase phase,
	int count
)

Parameters

phase Phase
The phase on which the rooms are to exist.
count Int32
The number of the rooms to be created.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
Exceptions
Exception Condition
InvalidOperationException If the room can not be created successfully or regeneration fails at the end of the creation.
ArgumentException Thrown if the phase does not exist in the given document.
See Also