Check integrity of content documents of all families loaded in the host document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The host document.
- corruptFamilyIds
- Type: System.Collections.Generic ISet ElementId
Return ids of families that need to be reloaded because their content documents are missing or corrupt.
Return Value
Returns true if all content documents are usable.Remarks
This check is slow as it invloves traversal of all content documents. It also dumps data about bad families into the journal, as well as the whole content tree into the dump file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |