CheckAllFamiliesSlow Method


Check integrity of content documents of all families loaded in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool CheckAllFamiliesSlow(
	Document ADoc,
	ISet<ElementId> corruptFamilyIds
)
Visual Basic
Public Shared Function CheckAllFamiliesSlow ( _
	ADoc As Document, _
	corruptFamilyIds As ISet(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CheckAllFamiliesSlow(
	Document^ ADoc, 
	ISet<ElementId^>^ corruptFamilyIds
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
The host document.
corruptFamilyIds
Type: System.Collections.GenericISetElementId
Return ids of families that need to be reloaded because their content documents are missing or corrupt.

Return Value

Returns true if all content documents are usable.

Remarks

This check is slow as it invloves traversal of all content documents. It also dumps data about bad families into the journal, as well as the whole content tree into the dump file.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also