Creates a new wall foundation within the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- typeId
- Type: Autodesk.Revit.DB ElementId
The id of the wall foundation type of the newly created wall foundation.
- wallId
- Type: Autodesk.Revit.DB ElementId
The id of the host wall of the newly created wall foundation.
Return Value
If successful, returns the newly created wall foundation, a null reference ( Nothing in Visual Basic) otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | typeId is not a valid WallFoundationType id. -or- wallId does not refer to a valid wall. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |