Create Method


Wall Foundation Create Method

Creates a new wall foundation within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static WallFoundation Create(
	Document document,
	ElementId typeId,
	ElementId wallId
)

Parameters

document Document
The document.
typeId ElementId
The id of the wall foundation type of the newly created wall foundation.
wallId ElementId
The id of the host wall of the newly created wall foundation.

Return Value

WallFoundation
If successful, returns the newly created wall foundation, otherwise.
Exceptions
Exception Condition
ArgumentException typeId is not a valid WallFoundationType id. -or- wallId does not refer to a valid wall.
ArgumentNullException A non-optional argument was null
See Also