The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
a null reference ( Nothing in Visual Basic) if the view is a template, or does not support cropping. If the view has a non-rectangular crop region, defined by a sketch, the crop box will be the smallest box that contains the sketch. Setting the crop box for a view with a non-rectangular crop region will have no effect. For better access to the crop region of a given view, regardless of the shape of the crop region, use the return from GetCropRegionShapeManager .Remarks
The X direction of the box is right on screen; Y is up; and Z is towards the user. The crop box Z value of a plan view is not meaningful.
Remarks
The effect of setting the crop box of a view is to modify the crop region and far clip plane to the smallest values which will completely contain the 3D box specified by the source. Neither the cut plane nor the view frame are affected by setting the crop box.
Remarks
Note: the Transform of the input BoundingBoxXYZ is ignored. Only Max and Min members of the input BoundingBoxXYZ are used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Cannot set the CropBox of the specified view. |