CropBox Property


View Crop Box Property

The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxXYZ CropBox { get; set; }

Property Value

BoundingBoxXYZ
if the view is a template, or does not support cropping. If the view has a non-rectangular crop region, defined by a sketch, the crop box will be the smallest box that contains the sketch. Setting the crop box for a view with a non-rectangular crop region will have no effect. For better access to the crop region of a given view, regardless of the shape of the crop region, use the return from GetCropRegionShapeManager .
Exceptions
Exception Condition
InvalidOperationException Cannot set the CropBox of the specified view.
Remarks
The X direction of the box is right on screen; Y is up; and Z is towards the user. The crop box Z value of a plan view is not meaningful.
See Also