Creates an instance of the DeleteElements resolution.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document which owns the element to delete.
- id
- Type: Autodesk.Revit.DB ElementId
The id of the element that will be deleted when this resolution is chosen.
Return Value
The instance of the DeletedElements resolution.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input id is not valid for deletion. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |