Create Method (Document, ElementId)


Delete Elements Create(Document, Element Id) Method

Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FailureResolution Create(
	Document document,
	ElementId id
)

Parameters

document Document
The document which owns the element to delete.
id ElementId
The id of the element that will be deleted when this resolution is chosen.

Return Value

FailureResolution
The instance of the DeletedElements resolution.
Exceptions
Exception Condition
ArgumentException The input id is not valid for deletion.
ArgumentNullException A non-optional argument was null
See Also