Creates a light family object from the given family document
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The family document
Return Value
The newly created LightFamily objectExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Document is the argument that is being validated The document is not valid because it is not a light family document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |